Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
v5.3.5 - many new features
#1
Hi all,

Wanted to post this in Announcements but I don't have access to, so I'll post it here. Gives us a chance to look at it too.

Features:
- Tolerance (for zombie detection) now adjustable in GUI
- Using AtoZ images for zombie search, Set B with Tolerance 65 with best results
- Added Threshold feature, will still attack a base even if it isn't zombie after X searches for a specified resource amount, adjustable in GUI
- Can now locate collectors now
- Can now collect with the collector locations
- Now detect resource change (gold, elixir and dark elixir) instead of just gold

edit: Uploaded new version with following fixes, ty so much for trying this version out and reporting any bugs!
- Including constants for UBound in case it is unable to find this automatically
- Clicks elsewhere when collecting to ensure it clicks properly on the next collector

edit2: After seeing the results from users, I just want to leave a warning that it seems not to be the most stable of the builds. If you want a stable build, I recommend 5.3.4. But if you want something with features that is built upon it, try this one. I am working on the bug fixes and will be releasing it as soon as I can.

edit3: Fixed the locate barracks and locate collectors and possibly other positioning issues. You can now download it, under zip: 2015-01-06_COC Bot v5.3.5.zip (the one in attachment is out of date now), do not use it. I am going to contact @Konloch to be able to add/edit attachments in the Announcement forum.

edit4: 2015-01-06b_COC Bot v5.3.5.zip now. I took the suggestion to change the name of the title but I am still not sure why this is happening, it might see another Window with the name which is why it caused it in the first place. Please let me know if you still get this error with this version.

edit5: 2015-01-07_COC Bot v5.3.5.zip
Reverted back to 5.3.4 by removing all of the 5.4 functions for the time being until sort out the whole memory leak issue. Added the reduced CPU fix that was suggested.
Also changed some of the timings. Such as collect() will happen after 5 trainings to avoid collecting for no reason. Next release will include the stop/start as a workaround for the hang issue.

edit6: Fixed quick bug, thanks SolidRain!

Happy botting Smile
Kaz

[attachment=29]
#2
@Kaz i test it just now but nothing happen its just say's Trying to get to main screen & thats it. no training troops or any thing else
#3
Testing it now. So far everything is working well. Only issue I have encountered is that it fails to collect resources. Dead base function is working, haven't had a chance to see if threshold is working yet though.
#4
Tested it.. yup collectors function is not working well..
Its takes 15seconds before it clicks return home.
It did not drop the heroes.
#5
Founded a bug ( bot is not running is come on startup after first correct start when click on start) ((located all self barracks/collectors//no located barracks/collectors - same error )

Line 1449 (File ''..... COC Bot v5.3.5.au3''): (same problem as exe)

For $i = 0 To UBound($collectorPos, $UBOUND_ROWS) - 1
For $i = 0 To UBound($collectorPos, ^ ERROR

Error: Variable used without being declared.
#6
Cannot detect barracks. Tried to locate manually, failed as well.
#7
I would cahnge line 1314 to
Quote:  Local $TrainPos = _PixelSearch(155, 603, 694, 605, Hex(0x603818, 6), 5) ;Finds Train Troops button

Otherwise it clicks the upgrade button when a barracks is not boosted or already maxed.
#8
Hi all,

Thank you for trying out this version! I have uploaded a new version with the fixes mentioned below in the first post.

@DarKForce Have you tried other versions of the bot? I need more information here. Have you located barracks? What's the resolution of your bluestacks?

@DiviniT3a It fails to collect because it still has a previous collector selected? It's the only reason I can see this happening because the location of the collectors are manually defined. I have corrected this, just like the barracks, it clicks elsewhere before clicking on the next building. This should resolve this issue.

As for clicking on the upgrade button when a barracks is not boosted or already maxed, have you seen this happen or it is a suspicion? I am using GkevinOD's 5.4's train() method, didn't see that issue come up in that thread.

@pinay26 Hopefully my fix of clicking elsewhere, it will work. Takes 15 seconds before it goes home after a battle? After a resource change? Please be more specific. The resource change wait is 30 seconds.
As for heroes, is there a version you are using where the heroes are being dropped? My heroes are in upgrade, and it is not a feature that I wanted to implemented yet.

@Kingchen This is very strange as no one else is getting this error. Which version of Autoit are you using? I've added to include AutoItConstants.au3 in the code.

@k3iroll Do you receive an error? What does it say in the log?
#9
Clicking the mouse to locate the location of the barracks and collectors doesn't work for me, the bot is clicking different points than what I located using the mouse. I need to go into the config file and manually enters the coordinates, only then the bot click the correct point (barracks & collectors)
#10
Hi Kaz,
I'm back from work, have now time Wink i'm using the v. 3.3.10.2 (latest stable)
Okay, i have now the ''same'' Error but now on the Line 1218 when i click ''locate collectors manually''
foundet another with same error but other line when i click start without manually locate --> Line 1579 // 1449
((Line 1218 (File ''..... COC Bot v5.3.5.au3''): (same problem as exe)
For $i = 0 To UBound($collectorPos, $UBOUND_ROWS) - 1
For $i = 0 To UBound($collectorPos, ^ ERROR
Error: Variable used without being declared.
 


Forum Jump:


Users browsing this thread: 1 Guest(s)



About The Bytecode Club

We're a community focused on Reverse Engineering, we try to target Java/Android but we also include other langauges/platforms. We pride ourselves in supporting and free and open sourced applications.

Website