Thread Rating:
  • 40 Vote(s) - 4.78 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5.4.2.5.2 - Better Troops Deployment (LF Style), Fixed Train Troops
#1
Brick 
Inspired by @barracoda @zax xtheo @GkevinOD @Antidote @Kaz @AtoZ

++++++++++++++++ PLEASE GIVE ME REPUTATION OR RATE THIS THREAD FOR MY WORK +++++++++++++++


This is an modified version from @GkevinOD v5.4.2.2:
  • This Bot include more troops settings
  • More Deploy Settings
  • Enable Donating menu for Barbarians, Archers and Giants. Thanks to @zax for DonateCC Functions
  • Fix getTrophy if DarkElixir is not available
  • Fix checkMainScreen function
  • Fix deadbase search on the background with hidden window
  • Implemented ZombieSearch from @AtoZ
  • Better deadbase search
  • Meet Max. TH Level 4-6, 7, 8, 9, 10 (new)
  • Meet Gold or Elixir (new)
  • Meet TH in Outside (new)
  • Attack outside townhall with barb and arch
  • Attack near townhall with Lightning Spell
  • Create spell
  • Attack TH with lightning spell
  • Reduce Out of Sync while searching
  • Smart Sleep While searching (new)
  • fixed waitmainscreen function
  • better troops deployment by @Fast French (new)
  • better train speed (new)
  • Wait 10 minutes when another device open the village (new)
  • Clan Castle drop option (new)
  • fixed locate barracks and collectors
  • fixed search mode
  • New bullymode. Check Attack TH in (Outside), bot will attack although not according to the conditions (new)
  • Custom icon
  • Fix minor bugs, etc
  • Many modified function to make it better
  • More Options will added in next update  Smile

NOTE:
- Donating Function are buggy, if you want to force Donate your Troops, just check "Donate to All" and Donate function will perfectly worked Wink wait for next update :D
- Sometime Townhall level is not detected when its locate in bottom of screen

If you got "Error cannot check for Dead Base, Attacking"
It because you was Run/Compile Script as x64 (it make dead base error).
TRY TO RUN IT AS X86, If you have the same issue. Try to re-install your AutoIt3

if you cant get deadbase mode work in background. Try this
(02-02-2015, 03:07 PM)SongHyeKyo Wrote:  @James and General Sam

Try this ..

(01-20-2015, 05:53 AM)ggwp Wrote:  This worked for me

http://www.guidingtech.com/5195/aero-eff...windows-7/

Run the check only after bluestacks changes your color scheme

source: https://the.bytecode.club/showthread.php?tid=325&page=4

If background mode still don't work, just uncheck background mode


Attached Files
.zip   COC Bot v5.4.2.5.1+Exe.zip (Size: 830.98 KB / Downloads: 1,235)
.zip   COC Bot v5.4.2.5.2+Exe.zip (Size: 832 KB / Downloads: 882)
.zip   COC Bot v5.4.2.5+Exe.zip (Size: 830.92 KB / Downloads: 130)
.zip   COC Bot v5.4.2.4.4+Exe.zip (Size: 818.88 KB / Downloads: 302)
.zip   COC Bot v5.4.2.4.5+Exe.zip (Size: 830.7 KB / Downloads: 684)
#2
this comes out when I click on the "start" button even though I choose any of the settings provided [Image: nwkizp.jpg] any solution for this?
BOT CLAN- JOIN NOW! FEEL FREE TO PM ME FOR THE CLAN NAME! Highfive
#3
(01-25-2015, 05:20 PM)jervisvgarcia Wrote:  this comes out when I click on the "start" button even though I choose any of the settings provided [Image: nwkizp.jpg] any solution for this?

Just Close then go to Troops options. Set your Troops Capacity like your Troops Capacity in your village, sorry for my bad english :D
#4
(01-25-2015, 05:22 PM)safar46 Wrote:  
(01-25-2015, 05:20 PM)jervisvgarcia Wrote:  this comes out when I click on the "start" button even though I choose any of the settings provided [Image: nwkizp.jpg] any solution for this?

Just Close then go to Troops options. Set your Troops Capacity like your Troops Capacity in your village, sorry for my bad english :D

still can't get it to work Sad I can't even manually locate my barracks just stucked on "getting to main screen" lol
BOT CLAN- JOIN NOW! FEEL FREE TO PM ME FOR THE CLAN NAME! Highfive
#5
@safar46 dude this update way to far Smile thanks for the update i will inform u if any error btw thanks Smile
#6
Thanks. Can I make a request. To make lightning spell then drop on DE storage while attacking village?
#7
(01-25-2015, 05:39 PM)jervisvgarcia Wrote:  
(01-25-2015, 05:22 PM)safar46 Wrote:  
(01-25-2015, 05:20 PM)jervisvgarcia Wrote:  this comes out when I click on the "start" button even though I choose any of the settings provided [Image: nwkizp.jpg] any solution for this?

Just Close then go to Troops options. Set your Troops Capacity like your Troops Capacity in your village, sorry for my bad english :D

still can't get it to work Sad I can't even manually locate my barracks just stucked on "getting to main screen" lol

After you open the Bot for first time, don't use "Locate Barracks Manually" button. Just Start your Bot and it automatically prompt you to set the barracks Wink

(01-25-2015, 05:42 PM)bushido-21 Wrote:  @safar46 dude this update way to far Smile thanks for the update i will inform u if any error btw thanks Smile

You're welcome. ok thanks back Smile

(01-25-2015, 05:44 PM)ssneoh Wrote:  Thanks. Can I make a request. To make lightning spell then drop on DE storage while attacking village?

I will try Wink
#8
@safar46 i have little request can you adjust into 1 or 2 min the watting when take a break popup for bot to click the reload thanks or where should i edit the script thanks Smile
#9
Donate function doesn't work on my side. It found the donate button pos but do nothing after.
#10
as of now the bot works like a charm Smile the deploy of any troops donate request looks great Smile thanks
 


Forum Jump:


Users browsing this thread: 1 Guest(s)



About The Bytecode Club

We're a community focused on Reverse Engineering, we try to target Java/Android but we also include other langauges/platforms. We pride ourselves in supporting and free and open sourced applications.

Website